By using this site, you agree to our Privacy Policy and our Terms of Use. Close

Forums - PC Discussion - Computer Build - no display

I built a computer recently; I have everything installed except the GPU.  However, my CPU should have integrated graphics.  The computer turns on, the fans turn on, but I am not getting any display output.  I know the HDMI cable and monitor are in working order.  I also noticed the CPU fan is not turning on.  I do have two CPU power connectors running to my modular PSU.  Any thoughts?  I am a bit lost on this one, plus a bit worried.  CPU not working?  MB Bios needs to be updated?  I have DDR5 ram, which my MB should support easily enough.    



i7-13700k

Vengeance 32 gb

RTX 4090 Ventus 3x E OC

Around the Network

What CPU do you have and you're sure it was seated in the socket correctly?

The CPU power connector doesn't affect the fan. There's a CPU fan connector on your motherboard that the fan needs to connect to turn on. It's just a little 4-pin connector that you have to look for.

Also, is your monitor set to HDMI source and not something like DisplayPort?

Here's an image I could find for the CPU fan connector. Depending on what CPU cooler you have, there should just be a single connector rather than the 2 displayed.



CPU is i7 13700k. The fans are connected to the MB via the 4 pins. Monitor is set to correct input, my other computer displays fine. Try repeating cpu?



i7-13700k

Vengeance 32 gb

RTX 4090 Ventus 3x E OC

Chrkeller said:

CPU is i7 13700k. The fans are connected to the MB via the 4 pins. Monitor is set to correct input, my other computer displays fine. Try repeating cpu?

Yeah that definitely has integrated graphics. And the MB you purchased is compatible with this CPU? Because idk if it's the case anymore because i use Ryzen, but Intel used to change the socket with every new gen line of CPUs, so if you upgraded your CPU, you had to upgrade your MB too. 

If you verified the MB is compatible with that CPU, also verify your RAM is compatible with that MB just to be on the safe side. After that, I would try reseating the CPU. I would also take the GPU from your other PC and install it on this new PC for troubleshooting purposes to see if you're able to get an image. 

Other than that, are there are any unusual beeps or something indicating an error?



Ram is ddr5 5600 and CPU is socket 1700.  It should work with my MSI pro z790-a.  Unless I'm missing something.  I'll try reseating



i7-13700k

Vengeance 32 gb

RTX 4090 Ventus 3x E OC

Around the Network
Chrkeller said:

Ram is ddr5 5600 and CPU is socket 1700.  It should work with my MSI pro z790-a.  Unless I'm missing something.  I'll try reseating

The MB's website does bring up this tidbit:

Supports DDR5 Memory, Dual Channel DDR5 7200+MHz (OC)
Idk if that's saying your memory needs to be at least 7200 though. 
Also, double check the box your CPU came in and make sure you didn't get the i7 13700KF. That F at the end means NO integrated graphics. 
I would still recommend, if possible, to take the GPU from the old PC and temporarily install it in the new one.



Thanks for the help.  I will give a few things a try and see how it goes.  



i7-13700k

Vengeance 32 gb

RTX 4090 Ventus 3x E OC

Chrkeller said:

Thanks for the help.  I will give a few things a try and see how it goes.  

Not a problem! There's only so much I can think off the top of my head without being hands on with the device lol, but hopefully there was something that'll help point you in the right direction. 

Good luck! 



Your motherboard also has debug LEDs that should tell you if any part of the boot process is failing:

I'd also make sure your CPU fan is connected to the CPU fan header:

I'd check that out

https://download.msi.com/archive/mnu_exe/mb/PROZ790-AWIFI.pdf

Last edited by Jizz_Beard_thePirate - on 10 November 2023

                  

PC Specs: CPU: 7800X3D || GPU: Strix 4090 || RAM: 32GB DDR5 6000 || Main SSD: WD 2TB SN850

Got it all working, at least I think so. Windows is installing. Best guess is I didn't have my ram fully seated.  

Thank you to all, the help was greatly appreciated.



i7-13700k

Vengeance 32 gb

RTX 4090 Ventus 3x E OC