Quantcast
Locked: Mention Capability - Fixed

Forums - Website Topics - Mention Capability - Fixed

As you all should know by now, awhile back I had added the ability to "mention" another user (ala Discord) by typing an "@" symbol, followed by the username. It was a rudimentary, hand-coded feature that sort of worked for the most part (barring the annoying notification, if somebody happened to quote a mentioned username). 

When I upgraded the text editor that you are all now using, I was able to implement a more sophisticated "mention" capability that provided for username lookup - this has now been fully implemented and is the ONLY way mentioning will work, from here forward (simply typing the "@" followed by a username will NO LONGER do anything - you MUST pick a username off the drop-down list that pops up, while typing the username).

You will know you've done it correctly, as users that are properly "mentioned" will have their username color-coded (depending on their role on the website):

SiteAdmin are red - @Machina 

GameDB are purple - @Bisa 

Moderators are green - @CGI-Quality 

Our PL Admin is pink - @kirby007 

Writers are blue - @trunkswd 

And general users are black - @SpokenTruth 

(...and yes, I've just annoyed each one of these users with a mention!!!)

Any troubles or problems, please let me know...

...oh, and the issue with quoted mentions is also fixed - you will no longer receive a secondary notification if somebody happens to quote a mentioned user!

Edit: At some point in the near future, I will further enhance this so that the mentioned usernames link to the user's profile. For now, they're just colored text.



Around the Network

What defines this color btw?



German YouTuber and Streamer:
StarCraft and Fallout 4 currently.

Me trying to write reviews:
Octopath Traveler

Amazon May 2019 thread

Not related but I thought you guys should know that replies don't work in the monmbile verison on Android, I have to request desktop view to reply. Also, I want to support but when I try I am locked into a Paypal only checkout and I can not remember my password, it seems paypal no longer aloows for a checkout without a sign in or having to create an account, is there any other way? As I would have like a year of silver teir had this not been an issue since my last supporter teir ran out.



 

Everything in the above reply is my opinion, from my own perspective and not representative of reality outside of my own head!

-Android user, please be gentle with critique on my spelling.

I did not get a notification @Talonman 

Edit and i don't get the dropdown menu



 "I think people should define the word crap" - Kirby007

Join the Prediction League http://www.vgchartz.com/predictions

Oh and as a black theme user, the black font on the general user mentions is very hard to see. Perhaps something more apparent on both balck and white backgrounds.



 

Everything in the above reply is my opinion, from my own perspective and not representative of reality outside of my own head!

-Android user, please be gentle with critique on my spelling.

Around the Network

@john2290



 

Everything in the above reply is my opinion, from my own perspective and not representative of reality outside of my own head!

-Android user, please be gentle with critique on my spelling.

John2290 said:
Not related but I thought you guys should know that replies don't work in the monmbile verison on Android, I have to request desktop view to reply. Also, I want to support but when I try I am locked into a Paypal only checkout and I can not remember my password, it seems paypal no longer aloows for a checkout without a sign in or having to create an account, is there any other way? As I would have like a year of silver teir had this not been an issue since my last supporter teir ran out.

Not sure what you mean by "replies don't work"? Do you mean, you aren't able to post ANY messages in the forums on mobile??

kirby007 said:

I did not get a notification @Talonman 

Edit and i don't get the dropdown menu

I didn't realize creating a new thread and replying, would use separate code for storage - so the mention code wasn't replicated in the new thread functionality. This has been fixed now (I just tested with a new thread and saw your mention, post).

Not sure why you wouldn't get the drop-down - is this in the "mobile" view?

John2290 said:
Oh and as a black theme user, the black font on the general user mentions is very hard to see. Perhaps something more apparent on both balck and white backgrounds.

I agree - this is something I noticed, myself.

John2290 said:
@john2290

This wouldn't have worked - are you also not seeing the drop-down? Were you in "mobile" when you posted this?



TalonMan said:
John2290 said:
Not related but I thought you guys should know that replies don't work in the monmbile verison on Android, I have to request desktop view to reply. Also, I want to support but when I try I am locked into a Paypal only checkout and I can not remember my password, it seems paypal no longer aloows for a checkout without a sign in or having to create an account, is there any other way? As I would have like a year of silver teir had this not been an issue since my last supporter teir ran out.

Not sure what you mean by "replies don't work"? Do you mean, you aren't able to post ANY messages in the forums on mobile??

kirby007 said:

I did not get a notification @Talonman 

Edit and i don't get the dropdown menu

I didn't realize creating a new thread and replying, would use separate code for storage - so the mention code wasn't replicated in the new thread functionality. This has been fixed now (I just tested with a new thread and saw your mention, post).

Not sure why you wouldn't get the drop-down - is this in the "mobile" view?

John2290 said:
Oh and as a black theme user, the black font on the general user mentions is very hard to see. Perhaps something more apparent on both balck and white backgrounds.

I agree - this is something I noticed, myself.

John2290 said:
@john2290

This wouldn't have worked - are you also not seeing the drop-down? Were you in "mobile" when you posted this?

I am able to reply but not qoute and it has to be a quick reply at the bottom of the thread as the reply button has the same issue. Only requesting the desktop site alleviates the issues. 

I was on mobile yes. 



 

Everything in the above reply is my opinion, from my own perspective and not representative of reality outside of my own head!

-Android user, please be gentle with critique on my spelling.

TalonMan said:

As you all should know by now, awhile back I had added the ability to "mention" another user (ala Discord) by typing an "@" symbol, followed by the username. It was a rudimentary, hand-coded feature that sort of worked for the most part (barring the annoying notification, if somebody happened to quote a mentioned username). 

When I upgraded the text editor that you are all now using, I was able to implement a more sophisticated "mention" capability that provided for username lookup - this has now been fully implemented and is the ONLY way mentioning will work, from here forward (simply typing the "@" followed by a username will NO LONGER do anything - you MUST pick a username off the drop-down list that pops up, while typing the username).

You will know you've done it correctly, as users that are properly "mentioned" will have their username color-coded (depending on their role on the website):

SiteAdmin are red - @Machina 

GameDB are purple - @Bisa 

Moderators are green - @CGI-Quality 

Our PL Admin is pink - @kirby007 

Writers are blue - @trunkswd 

And general users are black - @SpokenTruth 

(...and yes, I've just annoyed each one of these users with a mention!!!)

Any troubles or problems, please let me know...

...oh, and the issue with quoted mentions is also fixed - you will no longer receive a secondary notification if somebody happens to quote a mentioned user!

Edit: At some point in the near future, I will further enhance this so that the mentioned usernames link to the user's profile. For now, they're just colored text.

Couple of quick updates:

 1 - I discovered that using the mention while creating a new thread, wasn't working - this is fixed now. Just the same, since they didn't receive notifications in my original post, I'm gonna annoy them with notifications now!!

SiteAdmin are red - @Machina 

GameDB are purple - @Bisa 

Moderators are green - @CGI-Quality 

Our PL Admin is pink - @kirby007 

Writers are blue - @trunkswd 

And general users are black - @SpokenTruth 

2 - I'm aware the "black" for general users while using the "dark" theme, sucks - I'll work on a better color choice

3 - The mention capabilities will NOT work in the "mobile" version of the editor! This is an unfortunate restriction in the mobile interface, that I have no control over. Which means I'm forced into one or two decisions:

    - Allow for manually typing a "mention" as I had originally designed (the onus being on the user to correctly type the "@" sign, followed by the complete and accurate username)

    - Add a setting to the User Preference page, which will allow users to disable the mobile editor and see the full desktop version of the editor while in mobile.

I'm going to have to think on #3 here for a bit, before making a decision - so for now, please just be aware that there is an intentional limitation in the mobile editor, and that limitation is not something I can control at the moment... 



John2290 said:
TalonMan said:

Not sure what you mean by "replies don't work"? Do you mean, you aren't able to post ANY messages in the forums on mobile??

I didn't realize creating a new thread and replying, would use separate code for storage - so the mention code wasn't replicated in the new thread functionality. This has been fixed now (I just tested with a new thread and saw your mention, post).

Not sure why you wouldn't get the drop-down - is this in the "mobile" view?

I agree - this is something I noticed, myself.

This wouldn't have worked - are you also not seeing the drop-down? Were you in "mobile" when you posted this?

I am able to reply but not qoute and it has to be a quick reply at the bottom of the thread as the reply button has the same issue. Only requesting the desktop site alleviates the issues. 

I was on mobile yes. 

Ok - let's dig into this a bit more...

First, as I mentioned above - the mobile mention is currently unavailable (and, as I described in the OP, manually typing out the mention was intentionally scrapped). I will be revisiting this.

Second, and more important, let's figure out what's going on with your ability to reply in mobile. Obviously, the quick reply will always work because that's just a standard text box, nothing fancy - but I'm more interested in sorting out why you can't seem to use the editor. If you click "Reply" or "Quote" underneath a post, are you saying nothing at all happens??? What browserdevice are you using?