Quantcast
Halo 5 "lag" w/ Comcast connection.

Forums - Microsoft Discussion - Halo 5 "lag" w/ Comcast connection.

Tagged games:

Hey everyone,

    I've been really frustrated trying to figure out the source of my rubberbanding and lag spike issues. I started a Comcast account w/ 25mbps DL and 5mbps UL last year for Destiny and for the most part it works as good as it should(as well as said carrier does in my area anyways). However since Halo 5 came out it I have started to have a lot of issues.

When I test the speed with the speed test app it shows higher than what I pay for and a really good ping. When I test it from the Xbone the tests will sometimes say everything is great other times it says MTU issues or the UL and DL will vary but I don't get the same results from Speedtest on my phone(testing from Wifi and it usually reads a faster speed?). I use a Motorola modem I bought new and have my system wired either through the cheap router or I have or even tried just directly into my cable modem.

EDIT:I have tried different ethernet cables and MULTIPLE full resets.

My connectin does seem to be better over a much slower DSL wireless connection.

Anyone else have these issues...any suggestions on how I can try to make Comcast make sure my connection is more stable. Is it possible there is an issue with my system (btw it is a Day One console)? Or could it be just really bad luck when I play. Any feedback would be very welcome.



Make it So.

Around the Network

Didn't Comcast cap people's speed when streaming? They could be doing the same now with online playing sessions.

I could be wrong though, since I vaguely remember hearing about it.



Kirin_gaming said:

Didn't Comcast cap people's speed when streaming? They could be doing the same now with online playing sessions.

I could be wrong though, since I vaguely remember hearing about it.


You are not alone. I think it's a comcast only thing.



Oh man, Good thing Halo 5 has dedicated servers!... .   .    :P

OP: likely scenario, the servers used for H5 dedicated hosts, have poor routing for your IP block / location, and the DSL service you tried, while slower overall, has better routing to the dedicated hosts, resulting in better performance, I did try and explain this point in another thread but many predictably ignored it.

Possible solutions: reboot router entirely, if you're on a dynamic IP it *might* drop you on to another IP block thats has better linking and less hop congestion, if you're on a static IP, call comcast and ask them if they could change it for you, specifically state your reason and they should be able to help.

If they were using P2P network model for multiplayer, your solution would simply be "Leave the round and join another".



IP will almost certainly be dynamic. You have to pay extra for static.

Did I read you correctly in that your speed test over Wi-Fi on your phone results in faster speeds than your Xone with Ethernet?



Massimus - "Trump already has democrat support."

Around the Network
SpokenTruth said:
IP will almost certainly be dynamic. You have to pay extra for static.

Did I read you correctly in that your speed test over Wi-Fi on your phone results in faster speeds than your Xone with Ethernet?

 



Make it So.

OmegaRed421 said:
SpokenTruth said:
IP will almost certainly be dynamic. You have to pay extra for static.

Did I read you correctly in that your speed test over Wi-Fi on your phone results in faster speeds than your Xone with Ethernet?

 

 

Another thing to check, is go to "Network" and check your NAT type, if it says Strict or Moderate, "Test Multiplayer Connection" when the test is finnished, press both triggers and both bumper buttons all at once, youll see an advance info screen, under "Detailed NAT information", if you're on strict or moderate NAT type, it will likely say here, "Your network is behind a port-restricted NAT", back out of this and press all 4 buttons again, to go back to the detailed screen, keep doing this until detailed nat type says "Your network is behind a cone NAT", when it says this, back all the way out to network settings and it should now say your nat type is open, go play and see if that helps your issues.



Tachikoma said:

Another thing to check, is go to "Network" and check your NAT type, if it says Strict or Moderate, "Test Multiplayer Connection" when the test is finnished, press both triggers and both bumper buttons all at once, youll see an advance info screen, under "Detailed NAT information", if you're on strict or moderate NAT type, it will likely say here, "Your network is behind a port-restricted NAT", back out of this and press all 4 buttons again, to go back to the detailed screen, keep doing this until detailed nat type says "Your network is behind a cone NAT", when it says this, back all the way out to network settings and it should now say your nat type is open, go play and see if that helps your issues.

Didn't know about those screens, thanx. However my NAT is always open from being wired...I realized after playing with a moderate NAT type today on the wireless connection and having no issues it is the other connection itself. Was at work so i missed my appointment with Comcast. Hopefully I can this straighted out or I will jst drop the connection all together.



Make it So.

I have a wired Comcast connection with no problems. I have 75 down though. Try getting your Xbox closer to your router.



jlmurph2 said:

I have a wired Comcast connection with no problems. I have 75 down though. Try getting your Xbox closer to your router.


Like I said it is wired...and all of it is in my room...any closer and I'll have the modem and router on top of it, lol. I think the issue is something with their wires near my house.



Make it So.